infinity errors redirection system


#1

Hi there wanderful people,actually I created a directory protection to protect a folder in my website with password and username I used for that .htaccess and .htpasswd method, its working fine but when I enter a wrong password the page redirecting me to https://infinityfree.net/errors/500/ error page.
and when I request again the url path where the protected folder is , it keep redirecting and showing the same https://infinityfree.net/errors/500/ page always.
I dont want this to happened and I dont wanna use system redirection for any 400,401,403,404,500,503 errors .
all what I want is stopping it , I dont want to use any redirection system in my website
thank you.


#2

@MigaWeb said:
Hi there wanderful people,actually I created a directory protection to protect a folder in my website with password and username I used for that .htaccess and .htpasswd method, its working fine but when I enter a wrong password the page redirecting me to https://infinityfree.net/errors/500/ error page.
and when I request again the url path where the protected folder is , it keep redirecting and showing the same https://infinityfree.net/errors/500/ page always.
I dont want this to happened and I dont wanna use system redirection for any 400,401,403,404,500,503 errors .
all what I want is stop it , I dont want to use any redirection system in my website
thank you.

Update you .htaccess file!


#3

@Ranakhas said:

@MigaWeb said:
Hi there wanderful people,actually I created a directory protection to protect a folder in my website with password and username I used for that .htaccess and .htpasswd method, its working fine but when I enter a wrong password the page redirecting me to https://infinityfree.net/errors/500/ error page.
and when I request again the url path where the protected folder is , it keep redirecting and showing the same https://infinityfree.net/errors/500/ page always.
I dont want this to happened and I dont wanna use system redirection for any 400,401,403,404,500,503 errors .
all what I want is stop it , I dont want to use any redirection system in my website
thank you.

Update you .htaccess file!

How?


#4

@MigaWeb said:

@Ranakhas said:

@MigaWeb said:
Hi there wanderful people,actually I created a directory protection to protect a folder in my website with password and username I used for that .htaccess and .htpasswd method, its working fine but when I enter a wrong password the page redirecting me to https://infinityfree.net/errors/500/ error page.
and when I request again the url path where the protected folder is , it keep redirecting and showing the same https://infinityfree.net/errors/500/ page always.
I dont want this to happened and I dont wanna use system redirection for any 400,401,403,404,500,503 errors .
all what I want is stop it , I dont want to use any redirection system in my website
thank you.

Update you .htaccess file!

How?

Please Delete this lines on the .htaccess file

DirectoryIndex index.php index.html index2.html

ErrorDocument 400 https://infinityfree.net/errors/400
ErrorDocument 401 https://infinityfree.net/errors/401
ErrorDocument 403 https://infinityfree.net/errors/403
ErrorDocument 404 https://infinityfree.net/errors/404
ErrorDocument 500 https://infinityfree.net/errors/500
ErrorDocument 503 https://infinityfree.net/errors/503

And save the .htaccess file.


#5

@UnknownLolz said:

@MigaWeb said:

@Ranakhas said:

@MigaWeb said:
Hi there wanderful people,actually I created a directory protection to protect a folder in my website with password and username I used for that .htaccess and .htpasswd method, its working fine but when I enter a wrong password the page redirecting me to https://infinityfree.net/errors/500/ error page.
and when I request again the url path where the protected folder is , it keep redirecting and showing the same https://infinityfree.net/errors/500/ page always.
I dont want this to happened and I dont wanna use system redirection for any 400,401,403,404,500,503 errors .
all what I want is stop it , I dont want to use any redirection system in my website
thank you.

Update you .htaccess file!

How?

Please Delete this lines on the .htaccess file

DirectoryIndex index.php index.html index2.html

ErrorDocument 400 https://infinityfree.net/errors/400
ErrorDocument 401 https://infinityfree.net/errors/401
ErrorDocument 403 https://infinityfree.net/errors/403
ErrorDocument 404 https://infinityfree.net/errors/404
ErrorDocument 500 https://infinityfree.net/errors/500
ErrorDocument 503 https://infinityfree.net/errors/503

And save the .htaccess file.

Hi emm I Cant this file is not writable, I tried that


#6

@MigaWeb said:

@UnknownLolz said:

@MigaWeb said:

@Ranakhas said:

@MigaWeb said:
Hi there wanderful people,actually I created a directory protection to protect a folder in my website with password and username I used for that .htaccess and .htpasswd method, its working fine but when I enter a wrong password the page redirecting me to https://infinityfree.net/errors/500/ error page.
and when I request again the url path where the protected folder is , it keep redirecting and showing the same https://infinityfree.net/errors/500/ page always.
I dont want this to happened and I dont wanna use system redirection for any 400,401,403,404,500,503 errors .
all what I want is stop it , I dont want to use any redirection system in my website
thank you.

Update you .htaccess file!

How?

Please Delete this lines on the .htaccess file

DirectoryIndex index.php index.html index2.html

ErrorDocument 400 https://infinityfree.net/errors/400
ErrorDocument 401 https://infinityfree.net/errors/401
ErrorDocument 403 https://infinityfree.net/errors/403
ErrorDocument 404 https://infinityfree.net/errors/404
ErrorDocument 500 https://infinityfree.net/errors/500
ErrorDocument 503 https://infinityfree.net/errors/503

And save the .htaccess file.

Hi emm I Cant this file is not writable, I tried that

Where is that .htaccess file located?
You should edit the .htaccess file on your htdocs (public_html) folder.


#7

in the root where you can see your domains folders /.htacess


#8

@MigaWeb said:
in the root where you can see your domains folders /.htacess

Can you please give a screenshot when you try to save the .htaccess file?


#9

seloved I removed the .htaccess file i dont know how this happened but I successfully remove it even when its not writable


#10

@MigaWeb said:
seloved I removed the .htaccess file

And I recommend you to create another of it.
Since it’s a very good file for security on your website.

And also please insert this code to disable dir listing on your website.
Here is the code that you will only need to install on your .htaccess file to disable dir listing.
Options -Indexes


#11

@UnknownLolz said:

@MigaWeb said:
seloved I removed the .htaccess file

And I recommend you to create another of it.
Since it’s a very good file for security on your website.

And also please insert this code to disable dir listing on your website.
Here is the code that you will only need to install on your .htaccess file to disable dir listing.
Options -Indexes

Thank you so much @UnknownLolz


#12

@MigaWeb said:

@UnknownLolz said:

@MigaWeb said:
seloved I removed the .htaccess file

And I recommend you to create another of it.
Since it’s a very good file for security on your website.

And also please insert this code to disable dir listing on your website.
Here is the code that you will only need to install on your .htaccess file to disable dir listing.
Options -Indexes

Thank you so much @UnknownLolz

Your welcome and glad to help. :slight_smile:
Don’t hesitate to ask in the community forums of you want more support.


#13

@MigaWeb said:
seloved I removed the .htaccess file i dont know how this happened but I successfully remove it even when its not writable

You need to create a new .htaccess file in the htdocs directory of your message. It’s not possible to edit the main .htaccess for your account, but you can override all the rules in there in your own .htaccess file.


#14