Odd way of adding domain (CNAME, A, etc), some help?

Hello guys, admin/mod, my username is epiz_26757851.

I need to add my domain to my InfinityFree hosting, but for various reasons I can’t just set - in my domain’s control panel - the nameservers ns1/ns2.epizy.com. Here’s the thing:

You need to make sure your hosting provide gives you the DNS parameters of the web hosting. You’ll have to ask them to provide you with the name, the type and the value of the DNS record. It will be similar to this:

NAME: yourdomain. com TYPE: A VALUE: 123.123.123.123
NAME: www. yourdomain. com TYPE: CNAME VALUE: abc. example. com

WARNING

If your provider gives you ONLY the nameservers , such as ns1. provider. com, ns2. provider. com , you WON’T be able to add your domain . You need to contact the admin of your host and ask to have the SPECIFIC DNS details for web hosting.

So, what I have done is adding, in a table on my registar’s site, the following two records:

NAME: mynewdomain. com TYPE: A VALUE: my InfinityFree hosting’s IP address (found as explained in the Help page)
NAME: www. mynewdomain. com TYPE: CNAME VALUE: my Infinity Free “main domain” (found in the “account details” box)

My question is: is this correct? Anything else I need to do or things I need to change?

Thank you very much for your support!

matteventu

If your domain registrar doesn’t support adding nameservers to your domain, but only DNS records, you need to wait 90 days then transfer your domain to a domain registrar which supports changing nameservers (e.g. GoDaddy, NameCheap, NameSilo and so on), as there’s nothing you can do to add the domain with DNS records at the moment.

5 Likes

Thank you for the quick reply!

So even if I wait 72 hours after setting the two DNS records like I did, there’s no way to have it working, correct? :-/

Yesterday, right after I had added them, the domain was redirecting me to the “account suspended” page, while now instead the browser just gives me a “ERR_SSL_PROTOCOL_ERROR” message (even if I type the URL with http and not https, it redirects me to https domain and gives me that error).

No hope that there’s some SSL settings or something else that I can change to make it work, right?

Thank you again for your help!

Did you already add your own domain name to your hosting account? If not, then that’s the cause for both of these issues.

Sure, you can point your domain name to one of our website IPs, but doing so won’t make your site work. After all, we host thousands of accounts on a single IP address, so the server has no idea which website is related to a domain name if the domain is not added to an account.

So, I think these should be your next steps:

  1. Change the nameservers of your domain name to our nameservers.
  2. Add the domain to a hosting account (more info).
  3. (optionally) Move the domain name back to your own nameservers.
3 Likes