Problems with SMTP servers

I’ve seen many problems with this, but yet have not received a final answer. In the PNG attachment, you can see that the info entered is matching to the info here: https://www.lifewire.com/what-are-the-yandex-mail-smtp-settings-1171304
But then when I try to send a test email, this is the result:

Could not connect to the SMTP host.

This means your web server was unable to connect to smtp.yandex.com.

Typically this error is returned for one of the following reasons:

  • SMTP settings are incorrect (wrong port, security setting, incorrect host).
  • Your web server is blocking the connection.
  • Your SMTP host is rejecting the connection.

Recommended next steps:

  1. Triple check your SMTP settings including host address, email, and password, port, and security.
  2. Contact your web hosting provider and ask them to verify your server can connect to smtp.yandex.com on port 465 using tls encryption. Additionally, ask them if a firewall or security policy may be preventing the connection - many shared hosts block certain ports.
    3.Note: this is the most common cause of this issue.*
  3. Contact your SMTP host to confirm you are using the correct username and password.
  4. Verify with your SMTP host that your account has permissions to send emails using outside connections.

I have the correct login info, it’s just that it is not connecting. I am using WordPress plugin wp email SMTP to do this since I cant use the emails provided with the infinityfree plan. (InfinityFree does not give email accounts). I got my business email with yandex and I want to use that to send emails to my customers. My goal is to connect to Yandex servers and then use that as my smtp instead of the nonworking infinityfree domain emails.

I just copied this from their support center:


Look at the excerpt that I highlighted in yellow.

Or are you using Yandex.Mail360 for business?

If you are, they mention that you must use your application password, not the account password.

I think part of your issue is that you’ve selected TLS connection when Yandex uses SSL.

Your username and password are exactly the same as your account. Eg:

username: you@example.com
password: 1234
1 Like

I am using Yandex business, that’s why I have my custom domain… Will try Application Password

Thanks,
Casmat

Ive done account credentials correctly. Will try SSL.

Thanks,
Casmat

Ok, so I changed the type to SSL and when I did app password, it seams like I have gotten the connection to the server, but I can’t send mails. a new error came:

An issue was detected.

This means your test email was unable to be sent.

Typically this error is returned for one of the following reasons:

  • Plugin settings are incorrect (wrong SMTP settings, invalid Mailer configuration, etc).
  • Your web server is blocking the connection.
  • Your host is rejecting the connection.

Recommended next steps:

  1. Triple check the plugin settings, consider reconfiguring to make sure everything is correct (eg bad copy and paste).
  2. Contact your web hosting provider and ask them to verify your server can make outside connections. Additionally, ask them if a firewall or security policy may be preventing the connection - many shared hosts block certain ports.
    3.Note: this is the most common cause of this issue.*
  3. Try using a different mailer.

I think i’m getting closer, any suggestions?

This seems more like WP issue than something you’ve done. The only thing I can suggest is trying a different SMTP provider like Gmail to see if it is an internal issue.

1 Like

Always try to get the settings to be used directly from the source. So if you’re looking for Yandex’s email settings, you should find them either in your Yandex account or in the Yandex support portal.

Do not use third party articles as your main source, as those articles can be outdated or just wrong.

And it is, because the Yandex article say you should use port 465 with ssl encryption, not tls encryption like that article suggests.

This is not strange given that port 587 is normally used for tls encryption. Port 465 is always used with ssl encryption.

4 Likes

Ok

Yes, gmail works, because it is built in to the plugin

Arghh, I’m going to try contacting yandex because on my end, everything seems perfect… The yandex server is just disconnecting when I try to send mail. Any more help would be greatly appreciated!

Did you enable use portal password in your mail settings?

nope just app password

Thank you! I found I had mistyped some info :confused:! The plugin is now working correctly except for the fact that the plugin is showing a new “error” message:

Action Needed : It doesn’t look like the SPF record required by your SMTP server has been added to your domain. Please contact your SMTP server provider for details on how to find the SPF record, and how to add this record to your domain’s DNS.

I can’t add SPF records due to infinityfree not supporting TXT records (is there any way to add SPF records?) I am currently in touch with the yandex team and I will keep you in touch :slight_smile:

EDIT: I just remembered that you can add SPF records via cPanel. There is an option for it :slight_smile:

The only way you can add TXT records is by using a 3rd party DNS management system like Cloudflare.

Use this tutorial to help you:

4 Likes

Thank you! I figured out the SPF records before you replied, but I will need to use Cloudfare to add dmarc records. Do I need cloudfare to add DMARC records?

I have had problems with cloudfare because cloudfares SSL clashed with my SSL i had registered with infinityfree. Will all my existing dns records on infinityfree be still there?

You may have to transfer them, but generally Cloudflare automatically detects them.

1 Like

ok

Will changing nameservers remove anything on my website?