SPF record illegal characters error

Hi,

In the control panel, I am attempting to add an SPF record involving an at sign for purposes of having spam-protected email forwarding. However, when I do attempt to add such a record (e.g. of form “forward-email=somebody@somedomain.com”), I get error “Illegal characters in record part (forward-email=somebody@somedomain.com)”. Is this intentional or is there a way around this?

This may be too much information, but my account name is " epiz_26404382".

Thanks,
Brian

Hello there,

Could you tell us what is the SPF record you’re trying to add? Maybe sharing the SPF data here?

1 Like

With SPF, generally you specify a domain AUTHORISED for sending, or AUTHORISED ip addresses, like;

 v=spf1 a include:hn.fyi ~all

More detail is below;

1 Like

Hi,

I think I figured out that the service that I was planning on using (i.e. forwardemail DOT net) was using one kind of TXT record as a proprietary means of constraining how forwarding is done. Or, it’s a way of driving users towards paid plans. (If either of these explanations is right, then I suppose that even though SPF record can be considered a special kind of TXT record, for this specific TXT record it is not really a standard SPF record.)

Following is an address with instructions that I was following; in particular, I was looking at step four and option A:
https://forwardemail.net/en/faq?domain=something.com

(I also add an SPF record that looks more standard as part of step five: “v=spf1 a mx include:spf.forwardemail.net -all”.)

I have noticed that upon switching to improvmx DOT com, they do not ask me to add a TXT record involving “forward-email” and an at-sign. I’m not entirely sure if this comes at a cost of being more prone to having my emails be tagged as spam, however.

(continued)

(continued)

I apologize if I was not clear enough; the specific rule I am considering I already essentially mentioned. It was:
forward-email=somebody@somedomain.com

(Except, I have replaced my email which I do not wish to make too public with “somebody@somedomain.com”.)

Thanks,
Brian

(I apologize for the erratic-looking links and breaking up my response into two parts; as I am a new user, I am not allowed to add more than two links for each post, for some definition of link.)

I don’t know if you can use ‘forward-email’? Where did you get that from?

Hi,

Okay. I have checked RFC’s 4408 and 7208 and they indeed do not mention “forward-email=…”, so I suppose this must be an invention of forwardemail.net. Again, I got the idea of adding that TXT record via https://forwardemail.net/en/faq?domain=something.com in step four option A. It seems that that particular organization requires this TXT record for their free plan to know what behavior for their email forwarding service to have. (I experimented with option E in step four there and it only behaves s.t. the domain is swapped, but the user stays the same.)

Thanks,
Brian

1 Like

If it’s an invention of forwardemail.net then I don’t know if it is proper, I think that is for their system to recognise, not for SPF to recognise, same like this;

@ or leave blank 3600 TXT forward-email-port=1337

It is not universally recognised, and the forward-email, is a TXT record not SPF, it is only for their system, So you cannot add it, as it is a txt record.

Edit: Yep, Definately a TXT record

Hi,

I forgot to mention that I experimented with option E in step four because it is one of two options that don’t necessarily require an at-sign out of about six options. (Those two options are currently options E and F. Also, I have not attempted option F as it seems to be overly specific for my purposes.)

Alright, thanks for your help, HaydenANG. A consequence is that I will not be able to use forwardemail DOT net with infinity-free, given that my DNS service doesn’t allow TXT and NS records for the same subdomain at the same time and infinity-free doesn’t have option for their free plan for TXT records.

Thanks,
Brian

Yeah, But try using improvmx, and i use their SPF, to ensure that only they can forward mail;

v=spf1 include:spf.improvmx.com ~all