Mail Server

My website URL is: www. nordischetech.in
Hosted in this server .
Using mail server Yandex mail.
Changed the MX record to the described one 4 days back .
Still now DNS propagated.
Not receiving mails.

What I’m seeing is:

I’m using this software:

Additional information:

You may also have to add an SPF record. You can find a tutorial for this here.

Thanks for the prompt and wise reply , but the SPF record is not to send the spam mails I think. Doesn’t affect mail receiving.

1 Like

But SPF records help reduce the risk that emails sent from your domain go in the “Spam” folder on our inbox!

Right. will do that but 5 days past the DNS is not being propagated Thats eating me.

Check your MX records by using a service like mxtoolbox.com. And use the Yandex.Mail for Domains’ webmail service if you can’t receive emails, instead of using InfinityFree’s Roundcube installation.

MX tool is showing MX as mx.yandex.net still not receiving mails.

What webmail service are you using? The Yandex.Mail for Domains’ one, or our Roundcube installation? If it’s the former, you may be able to receive emails from there; if it’s the latter, please note that it works only with the MX record mx.byetcluster.com or mx.epizy.com.

Using Yandex.mail webmail service. But the nameservers are pointed to infinity server

You may need to create a mailbox for your domain first, and login to Yandex.Mail at least once with the email and password that you used at the time of creation, not the ones you used during registration to Yandex. You can find the same instructions, but complete, here.

1 Like

Created mailbox roopadas@nordischetech.in. Sent the mail from it. But not receiving the mails.
Furthermore 5 days past still https://www.digwebinterface.com/?hostnames=nordischetech.in&type=MX&ns=resolver&useresolver=8.8.4.4&nameservers=
with option MX record showing
nordischetech.in. 21599 IN MX 10 mx.epizy.com.
We are in a fix

So is the issue in sending emails FROM your domain or sending emails TO your domain?

MX records for a particular domain only control which servers are used to deliver email to. MX records don’t affect who can send email from your domain.

Why Yandex can’t get your email delivered is only something Yandex can tell you. But a good place to start is to try to send an email to https://www.mail-tester.com/ and see whether it’s Yandex which isn’t sending the email or the receiving providing not accepting it.

1 Like

Not receiving mails.
Changed MX record 5 days back.
Change is not showing .
Tested with mail tester. its ok .

Yes, you already said those exact words, but I don’t know who is not receiving what.

Is Yandex not receiving emails sent TO your domain? Or are other providers not receiving email sent FROM Yandex/your domain?

What is not showing where? Your MX records look fine from here.

1 Like

Yandex not receiving mail sent to my domain mail server.
MX record has been changed as mx.yandex.net but when checking in https://www.digwebinterface.com/?hostnames=nordischetech.in&type=MX&ns=resolver&useresolver=8.8.4.4&nameservers=
The result is
nordischetech.in. 7805 IN MX 10 mx.epizy.com.
So the MX entry is not changed.
5 days passed .
Thats the problem which i cant solve

Earlier i used roundcube mail
But it has som limitations .
Now I am using Yandex mail as my mail server.
I can send mail.
I cannot receive mail.
The problem in sending mail.
Mails are going to spam whenever sent to Gmail.
Corrected SPF. Cant put DKIM .Txt here. (Might be thats the problem)
The problem in receiving mail
Changed MX record . Change is not propagated. 5 days passed. Thats why not receiving any mails.
Please solve the above problems.
Happy Infinity free working

Hmm, very odd. Because Google says the mail server is mx.epizy.com but Cloudflare says it’s mx.yandex.net: https://www.digwebinterface.com/?hostnames=nordischetech.in&type=MX&ns=resolver&useresolver=1.1.1.1&nameservers=

Could you perhaps try to remove the existing MX records and then add it again? If there was any problem synchronizing your DNS records across our network, that should update the records again.

1 Like

MX records deleted and added again. The problem is not resolved . Please help

In https://www.digwebinterface.com/?hostnames=nordischetech.in&type=MX&ns=resolver&useresolver=8.8.4.4&nameservers=
Its showing
nordischetech.in. 10479 IN MX 10 mx.yandex.net. now.
But in https://www.digwebinterface.com/?hostnames=nordischetech.in&type=MX&ns=resolver&useresolver=8.8.4.4&nameservers=
its showing
nordischetech.in. 21562 IN MX 10 mx.epizy.com.
Whats The Falacy?
I am not receiving mails in my Yandex business mail server of mine till now.

I can see that some services show different information about MX record for my domain:

2whois shows that MX-record is configured correctly: https://2whois.ru/?t=nslookup&data=nordischetech.in&dns_type=mx .

However Digwebinterface shows the old MX-record: https://www.digwebinterface.com/?hostnames=nordischetech.in&type=MX&ns=resolver&useresolver=8.8.4.4&nameservers= .
Again
https://www.digwebinterface.com/?hostnames=nordischetech.in&type=MX&ns=resolver&useresolver=1.1.1.1&nameservers=

showing
nordischetech.in. 4632 IN MX 10 mx.yandex.net.

Please resolve