The Weirdest Problem With HTTPS!(NOT KIDDING)


#1

Hello InfinityFree Community.
I have a website,spesifically www.pctips.gq.
I used CloudFlare to get free Flexible SSL.
However,now my website in HTTPS looks completely different and damged than in HTTP!
Can anyone help me,especially @Admin ?
Thanks.


#2

Did you check the relevant KB article? https://infinityfree.net/support/how-to-make-your-website-use-https/


#3

It didn’t help me :frowning:
Anyway,does it have anything to do that in Softaculous I selected HTTP instead of HTTPS?
If then how can I change it to HTTPS?


#4

@ChrisPAR said:
It didn’t help me :frowning:
Anyway,does it have anything to do that in Softaculous I selected HTTP instead of HTTPS?
If then how can I change it to HTTPS?

Please @Admin anwser,I can’t find it myself :s :confused: :confused:


#5

@ChrisPAR said:
It didn’t help me :frowning:
Anyway,does it have anything to do that in Softaculous I selected HTTP instead of HTTPS?
If then how can I change it to HTTPS?

Did you verify that you completed all three steps in the article?


#6

@Admin The Problem is that to get my content delivered through HTTPS as described in the third part:> Make sure all urls use HTTPS
If your website has a valid SSL certificate and is using https, but you do not see a green lock, this is because some of the URLs on your website do not use https.

To get a green lock, all urls on the page must use https. All images, CSS and JavaScript files on the page must be loaded over https or the page will not be considered secure.

There are multiple ways to look for http urls. Sometimes, you may see “Mixed Content” in the JavaScript console in your browser, with the http URL next to it. You may also be able to view the source code of the page in your browser and look for http URLs there.

The next step is to find out what generated the bad URLs and how to fix them. Unfortunately, there is no general method to do so: it depends on many aspects of how you built your website.

i had to select https through sotaculous but now it is on http.
How can I change it?
I disabled redirecting all content to HTTPS due to this problem but I am re-enabling it now.
Please have in mind that I can’t make changes through wordpress when I am in HTTPS mode.


#7

? am really sorry for the pressure and trouble I put you into @Admin .


#8

So?What Happened?Did you find any solution?
BtW i found that some of my url’s are still deserved through http (I found itthrough source code).
I don’t know how to change it and it’s like i ruined my website.
@Admin help me please,I am getting crazy.


#9

@ChrisPAR said:
So?What Happened?Did you find any solution?
BtW i found that some of my url’s are still deserved through http (I found itthrough source code).
I don’t know how to change it and it’s like i ruined my website.
@Admin help me please,I am getting crazy.

Hello can you please let me know your domain?


#10

Oh never mind you already provided your domain above.


#11

@ChrisPAR said:
So?What Happened?Did you find any solution?
BtW i found that some of my url’s are still deserved through http (I found itthrough source code).
I don’t know how to change it and it’s like i ruined my website.
@Admin help me please,I am getting crazy.

Can you please delete the force https code on htaccess cause I want to compare your website with https and without https


#12

@UnknownLolz said:

@ChrisPAR said:
So?What Happened?Did you find any solution?
BtW i found that some of my url’s are still deserved through http (I found itthrough source code).
I don’t know how to change it and it’s like i ruined my website.
@Admin help me please,I am getting crazy.

Can you please delete the force https code on htaccess cause I want to compare your website with https and without https

I suggest you to use Automatic HTTP rewrites! Below is an Article but According to @Admin this is for sites with poor coding :frowning: but I think this is to save time.

How to Fix Insecure Content on Your Website without installing plugin!

Pics : 1&1 Hosting

Today I'm going to tell you that how you can fix insecure content on your site WP, Blogger, Forums or every site if you have SSL and all css and images can served over HTTPS you don't need to code don't need to do anything just step up site to CloudFlare!
If you are not using cloudflare then first setup.
Let's begin!
Open Cloudflare then visit https://www.cloudflare.com/a/crypto/yoursite.com Crypto setting found below the  Automatic HTTPS Rewrites like in below pics!

Just enable and everything will be fine!
Read more

#13

@Ranakhas said:

@UnknownLolz said:

@ChrisPAR said:
So?What Happened?Did you find any solution?
BtW i found that some of my url’s are still deserved through http (I found itthrough source code).
I don’t know how to change it and it’s like i ruined my website.
@Admin help me please,I am getting crazy.

Can you please delete the force https code on htaccess cause I want to compare your website with https and without https

I suggest you to use Automatic HTTP rewrites! Below is an Article but According to @Admin this is for sites with poor coding :frowning: but I think this is to save time.

How to Fix Insecure Content on Your Website without installing plugin!

Pics : 1&1 Hosting

Today I'm going to tell you that how you can fix insecure content on your site WP, Blogger, Forums or every site if you have SSL and all css and images can served over HTTPS you don't need to code don't need to do anything just step up site to CloudFlare!
If you are not using cloudflare then first setup.
Let's begin!
Open Cloudflare then visit https://www.cloudflare.com/a/crypto/yoursite.com Crypto setting found below the  Automatic HTTPS Rewrites like in below pics!

Just enable and everything will be fine!
Read more

But still remember if you enable automatic https rewrite and you have content on your website that can’t be change to https you are still stucked with your mixed content problem.


#14

@UnknownLolz said:
@Ranakhas said:

       @UnknownLolz said:

             @ChrisPAR said:
   So?What Happened?Did you find any solution?
   BtW i found that some of my url's are still deserved through http (I found itthrough source code).
   I don't know how to change it and it's like i ruined my website.
   @Admin help me please,I am getting crazy.

 



      Can you please delete the force https code on htaccess cause I want to compare your website with https and without https





  I suggest you to use Automatic HTTP rewrites! Below is an Article but According to @Admin this is for sites with poor coding  :( but I think this is to save time.

How to Fix Insecure Content on Your Website without installing plugin!

Pics : 1&1 Hosting >

Today I’m going to tell you that how you can fix insecure content on your site WP, Blogger, Forums or every site if you have SSL and all css and images can served over HTTPS you don’t need to code don’t need to do anything just step up site to CloudFlare!

If you are not using cloudflare then first setup.

Let’s begin!

Open Cloudflare then visit https://www.cloudflare.com/a/crypto/yoursite.com Crypto setting found below the Automatic HTTPS Rewrites like in below pics!

Just enable and everything will be fine!

 Read more 

But still remember if you enable automatic https rewrite and you have content on your website that can’t be change to https you are still stucked with your mixed content problem.
Yeah! I’ve mentioned above!


#15

I’m not a fan of the automatic rewrites if you don’t have to. Usually, you can just change your website settings or code to make it use HTTPS URLs itself. But either should solve the problem.


#16

@Admin said:
I’m not a fan of the automatic rewrites if you don’t have to. Usually, you can just change your website settings or code to make it use HTTPS URLs itself. But either should solve the problem.

Just like CNN do in 8 months!


#17

Thanks for the solutions,I will try them.
IT WORKED!
Thank you @Ranakhas

@Ranakhas said:

@UnknownLolz said:

@ChrisPAR said:
So?What Happened?Did you find any solution?
BtW i found that some of my url’s are still deserved through http (I found itthrough source code).
I don’t know how to change it and it’s like i ruined my website.
@Admin help me please,I am getting crazy.

Can you please delete the force https code on htaccess cause I want to compare your website with https and without https

I suggest you to use Automatic HTTP rewrites! Below is an Article but According to @Admin this is for sites with poor coding :frowning: but I think this is to save time.

How to Fix Insecure Content on Your Website without installing plugin!

Pics : 1&1 Hosting

Today I'm going to tell you that how you can fix insecure content on your site WP, Blogger, Forums or every site if you have SSL and all css and images can served over HTTPS you don't need to code don't need to do anything just step up site to CloudFlare!
If you are not using cloudflare then first setup.
Let's begin!
Open Cloudflare then visit https://www.cloudflare.com/a/crypto/yoursite.com Crypto setting found below the  Automatic HTTPS Rewrites like in below pics!

Just enable and everything will be fine!
Read more

#18

Weirdest Problem than ever!Now my site works,but whenever I try to login on Wordpress I receive error 508!
Can anyone give a possible explanation/solution?


#19

@ChrisPAR said:
Weirdest Problem than ever!Now my site works,but whenever I try to login on Wordpress I receive error 508!
Can anyone give a possible explanation/solution?

Help please.


#20

@ChrisPAR said:
@ChrisPAR said:
Weirdest Problem than ever!Now my site works,but whenever I try to login on Wordpress I receive error 508!
Can anyone give a possible explanation/solution?

Help please.
I think you should disable forcing HTTPS. Do not force traffic to HTTPS! First disable forcing then login to Dashboard change site URL from http to https this will resolve loop problem!